Hi Thomas,

Postgres has in its catalog many views with the prefix pg_stat<something>.
According to the documentation
<http://www.postgresql.org/docs/9.0/static/monitoring-stats.html>, the
'stat' word stands for statistics (for 'raw' data too). However, I think
that "metrics" is a good name. Can I proceed with this? If yes, which
columns we will add, I thought in the following columns:

store.unsavedMemory
store.fileStore.writeBytes
store.fileStore.readBytes
store.fileStore.writeCount
store.fileStore.readCount
store.fileStore.size
store.cache.usedMemory
store.cache.hits
store.cache.misses
store.chunkCache.usedMemory
store.chunkCache.hits
store.chunkCache.misses

As writeBytes and readBytes will be included in the new table, maybe would
be better remove info.FILE_WRITE and info.FILE_READ from settings meta
table.

Regards,

Fred
2015-03-11 4:45 GMT-03:00 Thomas Mueller <[email protected]>:

> Hi,
>
> I'm OK to use a new table name.
>
> I'm not sure what is the best name for this table. Most of the data is
> "raw", so it's not really statistics just yet. Sure, it can be used to
> generate statistics. Maybe "metrics"? What do other databases or storage
> systems use for this case?
>
> Regards,
> Thomas
>
>
>
> On Tuesday, March 10, 2015, Fred&Dani&Pandora&Aquiles <[email protected]>
> wrote:
>
>> Hi Thomas,
>>
>> That sounds like a good idea! On the API side, I would probably make it a
>>> key-value list, by extending the existing
>>> table information_schema.settings. Otherwise the table will get a *lot* of
>>> columns if we add other data. Of course, the problem of a key-value list is
>>> that the datatype for both keys and values is varchar, which is not needed
>>> here. But I don't think that's a big problem (right?).
>>>
>>>
>> I agree with you, as more informations are needed, more columns will be
>> added.
>>
>>
>>> Part of that info is already there, see for example "info.FILE_WRITE" in
>>> MetaTable.java
>>>
>>> What about using the following keys:
>>>
>>> store.unsavedMemory
>>> store.fileStore.writeBytes
>>> store.fileStore.readBytes
>>> store.fileStore.writeCount
>>> store.fileStore.readCount
>>> store.fileStore.size
>>> store.cache.usedMemory
>>> store.cache.hits
>>> store.cache.misses
>>> store.chunkCache.usedMemory
>>> store.chunkCache.hits
>>> store.chunkCache.misses
>>>
>>
>> I'm not sure if the meta table Setting is the best place to put this
>> stats. I can't see some I/O informations as database settings. IMHO, this
>> could 'pollute' the table with not necessarily related informations. What
>> you think about in create a separated meta table database_statistics and
>> put all related informations in key-value format?
>>
>> Regards,
>>
>> Fred
>>
>> --
>> You received this message because you are subscribed to the Google Groups
>> "H2 Database" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to [email protected].
>> To post to this group, send email to [email protected].
>> Visit this group at http://groups.google.com/group/h2-database.
>> For more options, visit https://groups.google.com/d/optout.
>>
>  --
> You received this message because you are subscribed to the Google Groups
> "H2 Database" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to [email protected].
> To post to this group, send email to [email protected].
> Visit this group at http://groups.google.com/group/h2-database.
> For more options, visit https://groups.google.com/d/optout.
>

-- 
You received this message because you are subscribed to the Google Groups "H2 
Database" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/h2-database.
For more options, visit https://groups.google.com/d/optout.

Reply via email to