On Tue, Dec 2, 2008 at 5:48 PM, Arthus Erea <[EMAIL PROTECTED]> wrote:
> I've been saying for a bit that our current implementation just seems
> a little... off. Our filter system should behave and look like the
> rest of Habari... where you use *methods* to get the data you want.
The 'data' from G/P in habari is mostly (few exception) done via
handler_vars array. Using methods to get data is not the best way as
you are getting a return value and isset/empty won't work. So you
would mix two different syntax' for common uses:
isset(Input::$get['trigger'])... Input::get('bar') ...
> Not only will this avoid any confusion about what $_* actually is, but
> I think it will also serve to make our code cleaner.
Your saying that Input::g/p/c, with a bool for raw data, and
Input::$g/p/c is less confusing?
--
Matt Read
http://mattread.com
--~--~---------~--~----~------------~-------~--~----~
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at http://groups.google.com/group/habari-dev
-~----------~----~----~----~------~----~------~--~---