Hi Vincent,

On Wed, Dec 28, 2016 at 09:42:29AM +0100, Vincent Bernat wrote:
>  ??? 28 décembre 2016 09:31 +0100, Vincent Bernat <ber...@luffy.cx> :
> 
> >> HAProxy 1.5.19 was released on 2016/12/25. It added 47 new commits
> >> after version 1.5.18.
> >
> > Would it be possible to queue this patch as well for the next 1.5 (if
> > any)?
> >
> > commit c6ca1aa34dd0e3999943c9a8754f447730b7563d
> > Author: Willy Tarreau <w...@1wt.eu>
> > Date:   Thu Oct 8 11:32:32 2015 +0200
> >
> >     MEDIUM: init: support more command line arguments after pid list
> >
> >     Given that all command line arguments start with a '-' and that
> >     no pid number can start with this character, there's no constraint
> >     to make the pid list the last argument. Let's relax this rule.
> >
> > This would enable to use the same init scripts for both 1.5 and 1.6.
> 
> On the other hand, this is not really useful without a088d316. So, maybe
> don't introduce another bug because of me and leave 1.5 as is. :)

Well, neither of them are hard to backport, so this is something we can
consider. However I'm making a difference between end-users requests and
maintainers' convenience. If you think it would really be useful to end
users one way or another, or if it solves some trouble you're facing
with the package maintenance, let's backport them. If it's just to keep
a single script to maintain, I think the benefit is low enough to avoid
a backport. Just let me know what you prefer, I'm fine with both options.

Willy

Reply via email to