Hi,

I just noticed the raw socket constructor was called __ssl_sock_deinit,
which is a bit confusing, and wrong twice, so the attached patch renames it
to __raw_sock_init, which seems more correct.
This is purely cosmetics.

Regards,

Olivier
>From 14821426ab9ff73fdb27a7a2259e54f2fd46f6bc Mon Sep 17 00:00:00 2001
From: Olivier Houchard <ohouch...@haproxy.com>
Date: Mon, 14 Aug 2017 15:59:44 +0200
Subject: [PATCH] MINOR: Use a better name for the constructor than
 __ssl_sock_deinit()

---
 src/raw_sock.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/raw_sock.c b/src/raw_sock.c
index 8aba58d7..707ba55f 100644
--- a/src/raw_sock.c
+++ b/src/raw_sock.c
@@ -429,7 +429,7 @@ static struct xprt_ops raw_sock = {
 
 
 __attribute__((constructor))
-static void __ssl_sock_deinit(void)
+static void __raw_sock_init(void)
 {
        xprt_register(XPRT_RAW, &raw_sock);
 }
-- 
2.13.3

Reply via email to