On Thu, May 09, 2019 at 03:52:45AM +0000, Chris Packham wrote:
> Hi,
> 
> I'm encountering the following linker error when building haproxy-1.9.7
> 
>    make CC=arm-softfloat-linux-gnueabi USE_OPENSSL=1
>    ...
>    LD      haproxy
>  
> /usr/bin/../lib/gcc/arm-softfloat-linux-gnueabi/8.3.0/../../../../arm-softfloat-linux-gnueabi/bin/ld:
>  
> src/fd.o: in function `fd_rm_from_fd_list':
>   haproxy-1.9.7/src/fd.c:267: undefined reference to `__ha_cas_dw'
>   collect2: error: ld returned 1 exit status
>   Makefile:994: recipe for target 'haproxy' failed
>   make: *** [haproxy] Error 1
> 
> Eyeballing the code I think it's because USE_THREAD is not defined and 
> __ha_cas_dw is only defined when USE_THREAD is defined
> 
> 

HAProxy is not supposed to build without a TARGET argument, I can't reproduce
your problem, what is your complete make line?

-- 
William Lallemand

Reply via email to