hello,

please consider attached patch

Ilya Shipitsin
From b65dc30f1c07aca067ebb31d373833fe66486b7b Mon Sep 17 00:00:00 2001
From: Ilya Shipitsin <chipits...@gmail.com>
Date: Thu, 19 Sep 2019 23:32:30 +0500
Subject: [PATCH] BUILD: travis-ci: add PCRE2, SLZ build

---
 .travis.yml | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

diff --git a/.travis.yml b/.travis.yml
index 8fb906409..879a676ae 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -13,7 +13,7 @@ env:
 
 addons:
   apt:
-    packages: [ liblua5.3-dev, libsystemd-dev ]
+    packages: [ liblua5.3-dev, libsystemd-dev, libpcre2-dev ]
 
 cache:
   directories:
@@ -74,6 +74,13 @@ matrix:
       - choco install bash make libssl-devel cygwin-devel gcc-core libgcc1 binutils lua-devel libpcre-devel zlib-devel --source cygwin
     script:
       - C:\\tools\\cygwin\\bin\\bash -lc 'cd $OLDPWD && make TARGET=cygwin USE_ZLIB=1 USE_PCRE=1 USE_PCRE_JIT=1 USE_LUA=1 USE_OPENSSL=1 USE_THREAD=1 && ./haproxy -vv'
+  - os: linux
+    if: type == cron
+    compiler: clang
+    env: TARGET=linux-glibc FLAGS="USE_SLZ=1 USE_PCRE2=1 USE_PCRE2_JIT=1 USE_LUA=1 USE_OPENSSL=1 USE_SYSTEMD=1 USE_WURFL=1 WURFL_INC=contrib/wurfl WURFL_LIB=contrib/wurfl USE_51DEGREES=1"
+    before_script:
+      - git clone http://git.1wt.eu/git/libslz.git/
+      - cd libslz && make && make PREFIX=${HOME}/opt install && cd ..
 
 install:
   - git clone https://github.com/VTest/VTest.git ../vtest
-- 
2.20.1

Reply via email to