On Wed, 12 Aug 2009, Szak�ts Viktor wrote: >>> ; TODO: Streamline macro usage regarding external dependencies. >>> There is currently HAS*, HAVE*, HB_HAVE*, HB_WITHOUT* >>> plus some other variations. >>> We should probably stick to HB_BUILD_WITH_* for user >>> level control, and HB_HAS_* for internal detection logic. >> We need two vars. >> One to include non default parts and second to exclude default parts. > This could still mean one setting which can be set to yes/no > with proper yes/no systems defaults.
OK, I haven't understood what you are asking for. Now it's clear for me. Please also change compile time macro HAVE_GPM_H to HB_HAS_GPM I would like to use HB_HAS_ prefix for all such macros. It will help to locate them if we add support for autoconf. best regards, Przemek _______________________________________________ Harbour mailing list [email protected] http://lists.harbour-project.org/mailman/listinfo/harbour
