If you are on linux by default Csound uses pulseaudio or default sound card.
The concrete driver can be chosen with flags (Csound.Options)

Maybe your version for ghc+cabal is too old. ghc 7.10 + is recommended




2017-07-17 8:43 GMT+03:00 Henning Thielemann <lemm...@henning-thielemann.de>
:

>
> On Mon, 17 Jul 2017, '2+ wrote:
>
> > am a python+csound guy who is always struggling in vain to setup haskell
> related things
> > such as installing tidalcycles on my cheap linux machines
> > and since am more into oscillators than samples
> > and since i hate using jack that doesnt wanna work on many of my machines
> > am almost making my mind to use csound-expression as my live-coding
> environment
>
> I think I never used Csound with JACK thus I am pretty sure that Csound
> works without.
>
> > but it ain't clear whether it works without jack
> > and my
> > cabal install csound-expression
> > on my chromebook-crouton-cli-extra
> > resulted into:
> >
> > user error (The package 'csound-expression-typed' requires Cabal library
> > version -any && >=1.22 but no suitable version is installed.
> >
> > my crouton is still debian-jessie
> > maybe that's the prob
> > but do you think it will go well if i upgrade
>
> For Ubuntu there are Deb packages for newer versions of Cabal:
>     http://ppa.launchpad.net/hvr/ghc/ubuntu
>
> But you should be able to upgrade to a new version of cabal using:
>     cabal install cabal-install-1.24.0.2
>
> --
>
> Read the whole topic here: Haskell Art:
> http://lurk.org/r/topic/4LlnlASO2QhhrcwXfmk3vS
>
> To leave Haskell Art, email haskell-art@group.lurk.org with the following
> email subject: unsubscribe
>

-- 

Read the whole topic here: Haskell Art:
http://lurk.org/r/topic/5wJGCQbeJBR4GnV4Lkf7JP

To leave Haskell Art, email haskell-art@group.lurk.org with the following email 
subject: unsubscribe

Reply via email to