A couple of quick comments:

I said in my last email that the refactored Haskore would be released as 
one "package", and I wanted to make it clear that by that I did not mean 
one "module"!  Henning and I both believe in using a hierarchical 
namespace, qualified imports, etc.to support as many modules as is 
necessary to create a coherent, sensible overall design.

It might make sense to break up Haskore into a couple of different 
packages, as I believe Stefan Kersten suggested.  I will have to think 
more about that.  It might also make sense to release a couple of 
standard wrapper modules that set up typical use cases of Haskore.

What Henning and I don't quite agree on is the use of the "Modula II" 
style of naming datatypes, e.g. Haskore.Duration.T, etc.  I personally 
find this confusing (as did many of my students), and would prefer a 
more mnemonic name, even if redundant.  I prefer to think of a module as 
encapsulating a single coherent concept, and sometimes that concept 
involves more than one data type, or perhaps none at all (being, 
perhaps, a collection of functions or type classes), in which case the 
"T" naming convention become problematical.

In any case, independent of the naming convention, the current module 
breakdown, and naming hierarchy, needs to be re-thought.

    -Paul






_______________________________________________
haskell-art mailing list
haskell-art@lists.lurk.org
http://lists.lurk.org/mailman/listinfo/haskell-art

Reply via email to