On 19 October 2011 17:03, Johan Tibell <johan.tib...@gmail.com> wrote:
> Have a look at:
>
> https://github.com/tibbe/unordered-containers/blob/master/benchmarks/Benchmarks.hs

I see you use the (evaluate . rnf) composition.

I also used it in:

https://github.com/basvandijk/vector-bytestring/blob/master/bench.hs#L118

and called it:

deepEvaluate :: NFData a => a -> IO ()
deepEvaluate = evaluate . rnf

I'm not sure about the name but I think it would be nice if this was
added to Control.DeepSeq.

Bas

_______________________________________________
Haskell-Cafe mailing list
Haskell-Cafe@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-cafe

Reply via email to