http://hackage.haskell.org/trac/haskell-prime/wiki/Underscore

I think it is basically the wrong idea to encode (type and) usage
information in the name of an identifier. One should use the type system
for that, or, failing that, annotations. Something like

data Foo = Foo | @SuppressWarnings("unused") Bar

See my proposal for unified and extendible annotations
http://www.haskell.org//pipermail/haskell-prime/2006-February/000279.html
http://java.sun.com/docs/books/tutorial/java/javaOO/annotations.html

Of course compilers/IDEs are free to support whatever naming conventions
they want but I think such conventions should not go into the language
standard.

Best regards,
-- 
-- Johannes Waldmann -- Tel/Fax (0341) 3076 6479/80 --
---- http://www.imn.htwk-leipzig.de/~waldmann/ -------

_______________________________________________
Haskell-prime mailing list
Haskell-prime@haskell.org
http://haskell.org/mailman/listinfo/haskell-prime

Reply via email to