| What is not so nice is that you take a new keyword ('for'), which is
| quite likely to have been used as a variable name in existing code.
(Or
| does it work out to use one of the 'special' names here?)

The latter is what Bjorn has done.  That is, 'for' is only special in
this one context.  You can use it freely otherwise.  As I understand it
anyway.

| I think it would be useful to write the proposal in complete detail up
| on the Haskell' wiki.

Yes please.  Bjorn?  (It may just be a qn of transcribing the user
manual stuff you have written.)

S
_______________________________________________
Haskell-prime mailing list
Haskell-prime@haskell.org
http://www.haskell.org/mailman/listinfo/haskell-prime

Reply via email to