[
https://issues.apache.org/jira/browse/HCATALOG-192?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13190185#comment-13190185
]
[email protected] commented on HCATALOG-192:
--------------------------------------------------------
-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/3291/#review4506
-----------------------------------------------------------
Is there an easy way either in unit tests or e2e tests for failure scenarios.
It will be great if we have coverage for abortJob() methods which aborts ZK
transactions.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java
<https://reviews.apache.org/r/3291/#comment10099>
qualifiedTableName sounds better name to me.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java
<https://reviews.apache.org/r/3291/#comment10101>
Since we are already serializing the full Txn object, there is no need to
serialize rev number seperately. Rev number can be fetched from serialized Txn
object.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseConstants.java
<https://reviews.apache.org/r/3291/#comment10100>
Word property is redundant in variable name. Get rid of it. This also holds
for other variable names in this file.
- Ashutosh
On 2012-01-18 06:13:50, Francis Liu wrote:
bq.
bq. -----------------------------------------------------------
bq. This is an automatically generated e-mail. To reply, visit:
bq. https://reviews.apache.org/r/3291/
bq. -----------------------------------------------------------
bq.
bq. (Updated 2012-01-18 06:13:50)
bq.
bq.
bq. Review request for hcatalog, Ashutosh Chauhan, Vandana Ayyalasomayajula,
and David Capwell.
bq.
bq.
bq. Summary
bq. -------
bq.
bq. Integrated write transactions in HBase OSD.
bq.
bq.
bq. This addresses bug hcatalog-192.
bq. https://issues.apache.org/jira/browse/hcatalog-192
bq.
bq.
bq. Diffs
bq. -----
bq.
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBaseOutputStorageDriver.java
8ba0e8a
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBulkOutputFormat.java
004e3df
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseBulkOutputStorageDriver.java
bdc06ce
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseConstants.java
b3b90ab
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseDirectOutputFormat.java
706c911
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseHCatStorageHandler.java
99b92b1
bq.
storage-drivers/hbase/src/java/org/apache/hcatalog/hbase/HBaseSerDeResultConverter.java
5eac5b8
bq.
storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseBulkOutputStorageDriver.java
57b4928
bq.
storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseDirectOutputStorageDriver.java
b7182fd
bq.
storage-drivers/hbase/src/test/org/apache/hcatalog/hbase/TestHBaseSerDeResultConverter.java
d6215ed
bq.
bq. Diff: https://reviews.apache.org/r/3291/diff
bq.
bq.
bq. Testing
bq. -------
bq.
bq. Updated units tests, also had to remove two that were no longer needed.
All tests passed.
bq.
bq.
bq. Thanks,
bq.
bq. Francis
bq.
bq.
> HBase output storage driver integration with zookeeper based revision manager
> -----------------------------------------------------------------------------
>
> Key: HCATALOG-192
> URL: https://issues.apache.org/jira/browse/HCATALOG-192
> Project: HCatalog
> Issue Type: Sub-task
> Components: hbase
> Affects Versions: 0.3
> Reporter: Vandana Ayyalasomayajula
> Assignee: Francis Liu
> Priority: Minor
> Labels: hbase, storage_drivers
> Fix For: 0.3
>
> Attachments: HCATALOG-192.patch, HCATALOG-192_2.patch
>
>
> This jira deals with the integration of the HBase output storage driver with
> the zookeeper based revision manager.
--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:
https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira