Author: jghoman
Date: Wed Jun 9 21:47:24 2010
New Revision: 953168
URL: http://svn.apache.org/viewvc?rev=953168&view=rev
Log:
HDFS-1190. Remove unused getNamenode() method from DataNode. Contributed by
Jeff Ames.
Modified:
hadoop/hdfs/trunk/CHANGES.txt
hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
Modified: hadoop/hdfs/trunk/CHANGES.txt
URL:
http://svn.apache.org/viewvc/hadoop/hdfs/trunk/CHANGES.txt?rev=953168&r1=953167&r2=953168&view=diff
==============================================================================
--- hadoop/hdfs/trunk/CHANGES.txt (original)
+++ hadoop/hdfs/trunk/CHANGES.txt Wed Jun 9 21:47:24 2010
@@ -41,6 +41,9 @@ Trunk (unreleased changes)
HDFS-1183. Remove some duplicate code in NamenodeJspHelper.java.
(Jeff Ames via jghoman)
+
+ HDFS-1190. Remove unused getNamenode() method from DataNode.
+ (Jeff Ames via jghoman)
BUG FIXES
Modified:
hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
URL:
http://svn.apache.org/viewvc/hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java?rev=953168&r1=953167&r2=953168&view=diff
==============================================================================
---
hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
(original)
+++
hadoop/hdfs/trunk/src/java/org/apache/hadoop/hdfs/server/datanode/DataNode.java
Wed Jun 9 21:47:24 2010
@@ -533,14 +533,6 @@ public class DataNode extends Configured
return dnRegistration;
}
- /**
- * Return the namenode's identifier
- */
- public String getNamenode() {
- //return namenode.toString();
- return "<namenode>";
- }
-
public static void setNewStorageID(DatanodeRegistration dnReg) {
/* Return
* "DS-randInt-ipaddr-currentTimeMillis"