ZanderXu created HDFS-16709:
-------------------------------
Summary: Remove redundant cast in FSEditLogOp.class
Key: HDFS-16709
URL: https://issues.apache.org/jira/browse/HDFS-16709
Project: Hadoop HDFS
Issue Type: Improvement
Reporter: ZanderXu
Assignee: ZanderXu
When I read some class about Edits of NameNode, I found that there are much
redundant cast inĀ FSEditLogOp.class, I feel that we should remove them.
Such as:
{code:java}
static UpdateBlocksOp getInstance(OpInstanceCache cache) {
return (UpdateBlocksOp)cache.get(OP_UPDATE_BLOCKS);
} {code}
Because cache.get() have cast the response to T, such as:
{code:java}
@SuppressWarnings("unchecked")
public <T extends FSEditLogOp> T get(FSEditLogOpCodes opCode) {
return useCache ? (T)CACHE.get().get(opCode) : (T)newInstance(opCode);
} {code}
--
This message was sent by Atlassian Jira
(v8.20.10#820010)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]