[ 
https://issues.apache.org/jira/browse/HDFS-8446?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14588964#comment-14588964
 ] 

Jing Zhao commented on HDFS-8446:
---------------------------------

# Printing out the file paths can still be useful here.
{code}
    Preconditions.checkArgument(offset >= 0,
        "Negative offset is not supported.");
    Preconditions.checkArgument(length >= 0,
        "Negative length is not supported.");
{code}
# {{resolvePath}} should also be put into the try section since it can throw 
exceptions.
{code}
fsd.readLock();
    src = fsd.resolvePath(pc, src, pathComponents);
    try {
....
{code}


> Separate safemode related operations in GetBlockLocations()
> -----------------------------------------------------------
>
>                 Key: HDFS-8446
>                 URL: https://issues.apache.org/jira/browse/HDFS-8446
>             Project: Hadoop HDFS
>          Issue Type: Bug
>            Reporter: Haohui Mai
>            Assignee: Haohui Mai
>            Priority: Minor
>         Attachments: HDFS-8446.000.patch, HDFS-8446.001.patch, 
> HDFS-8446.002.patch
>
>
> Currently {{FSNamesystem#GetBlockLocations()}} has some special cases when 
> the NN is in SafeMode. This jira proposes to refactor the code to improve 
> readability.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Reply via email to