[
https://issues.apache.org/jira/browse/HDFS-9350?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14985387#comment-14985387
]
Daryn Sharp commented on HDFS-9350:
-----------------------------------
I know SB should be used to append inside a loop, but doesn't the jvm use a SB
internally for simple plus operations? If yes, explicit use of a SB only seems
to decrease readability.
> Avoid creating temprorary strings in Block.toString() and getBlockName()
> ------------------------------------------------------------------------
>
> Key: HDFS-9350
> URL: https://issues.apache.org/jira/browse/HDFS-9350
> Project: Hadoop HDFS
> Issue Type: Improvement
> Components: performance
> Affects Versions: 2.7.1
> Reporter: Staffan Friberg
> Assignee: Staffan Friberg
> Priority: Minor
> Attachments: HDFS-9350.001.patch
>
>
> Minor change to use StringBuilders directly to avoid creating temporary
> strings of Long and Block name when doing toString on a Block.
--
This message was sent by Atlassian JIRA
(v6.3.4#6332)