Anu Engineer commented on HDFS-7878:

Yes, I think we should use {{BikeShed}} class instead of long, given that we 
might want to inherit from it. 
I also love the fact that {{BikeShed}} is an abstract class, so I can inherit 
all wonderfully *colored* {{BikeSheds}}. 

On a more serious note : I am {{+1}} on version 6 of this patch. This patch 
seems to have addressed all substantive comments we have had on this issue.  

Since this is going into Alpha-2, why don't we commit this and then discuss 
renaming {{InodeId}} to {{BikeShed}} or whatever it is going to be named in a 
separate Jira.

> API - expose an unique file identifier
> --------------------------------------
>                 Key: HDFS-7878
>                 URL: https://issues.apache.org/jira/browse/HDFS-7878
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>            Reporter: Sergey Shelukhin
>            Assignee: Sergey Shelukhin
>              Labels: BB2015-05-TBR
>         Attachments: HDFS-7878.01.patch, HDFS-7878.02.patch, 
> HDFS-7878.03.patch, HDFS-7878.04.patch, HDFS-7878.05.patch, 
> HDFS-7878.06.patch, HDFS-7878.patch
> See HDFS-487.
> Even though that is resolved as duplicate, the ID is actually not exposed by 
> the JIRA it supposedly duplicates.
> INode ID for the file should be easy to expose; alternatively ID could be 
> derived from block IDs, to account for appends...
> This is useful e.g. for cache key by file, to make sure cache stays correct 
> when file is overwritten.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to