Andrew Wang commented on HDFS-10999:

Yea, thanks for the pointer [~rakesh_r]. One idea is that we could add new 
metrics with more accurate names and deprecate the old ones for Hadoop 3. Then 
Hadoop 4, consider removing them.

For the webui, I think we can migrate it over directly, since it's not covered 
by compatibility. Web users are supposed to parse /jmx output instead, which is 

It's a bit trickier for shell commands. Empirically, people do parse the output 
of commands like dfsadmin and fsck. Having double prints for both the old and 
new names is kind of ugly.

[~aw] any thoughts on how best to migrate the names for the shell tools?

> Use more generic "low redundancy" blocks instead of "under replicated" blocks
> -----------------------------------------------------------------------------
>                 Key: HDFS-10999
>                 URL: https://issues.apache.org/jira/browse/HDFS-10999
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: erasure-coding
>    Affects Versions: 3.0.0-alpha1
>            Reporter: Wei-Chiu Chuang
>            Assignee: Yuanbo Liu
>              Labels: supportability
> Per HDFS-9857, it seems in the Hadoop 3 world, people prefer the more generic 
> term "low redundancy" to the old-fashioned "under replicated". But this term 
> is still being used in messages in several places, such as web ui, dfsadmin 
> and fsck. We should probably change them to avoid confusion.
> File this jira to discuss it.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to