Uma Maheswara Rao G commented on HDFS-11669:

Thanks for reporting JIRA [~surendrasingh]. Its reasonable to have the option 
as we thought of having an hybrid API which should do set and satisfy. Instead 
of having option name as satisfy, should it more meaningful if we say 
-scheduleBlockMoves ?
What others think on this?

> [SPS]: Add option in "setStoragePolicy" command to satisfy the policy.
> ----------------------------------------------------------------------
>                 Key: HDFS-11669
>                 URL: https://issues.apache.org/jira/browse/HDFS-11669
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: namenode, shell
>    Affects Versions: HDFS-10285
>            Reporter: Surendra Singh Lilhore
>            Assignee: Surendra Singh Lilhore
> Add one new option {{-satisfypolicy}} in {{setStoragePolicy}} command to 
> satisfy the storage policy.
> {noformat}
> hdfs storagepolicies -setStoragePolicy -path <path> -policy <policy> 
> -satisfypolicy
> {noformat}

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to