Anu Engineer commented on HDFS-12196:

[~cheersyang] +1 for v5 patch, pending Jenkins. 

I have a small nit, which *we don't need to address* in this patch. My 
apologies that I did not spot it earlier.
Instead of the word *recycling* can we use the word *delete*? I feel that it is 
easier to understand.

Rename ContainerRecyclingService to something like BlockDeletingService. 

Also, change the comment for this class to something like:
A per-datanode block deleting service that deletes 
blocks from active containers.

You don't have to do this now, please feel free to commit. I know you have 3 
more checkins pending on this, so feel free to modify this name is some later 

> Ozone: DeleteKey-2: Implement container recycling service to delete stale 
> blocks at background
> ----------------------------------------------------------------------------------------------
>                 Key: HDFS-12196
>                 URL: https://issues.apache.org/jira/browse/HDFS-12196
>             Project: Hadoop HDFS
>          Issue Type: Sub-task
>          Components: ozone
>            Reporter: Weiwei Yang
>            Assignee: Weiwei Yang
>         Attachments: HDFS-12196-HDFS-7240.001.patch, 
> HDFS-12196-HDFS-7240.002.patch, HDFS-12196-HDFS-7240.003.patch, 
> HDFS-12196-HDFS-7240.004.patch, HDFS-12196-HDFS-7240.005.patch
> Implement a recycling service running on datanode to delete stale blocks.  
> The recycling service scans staled blocks for each container and delete 
> chunks and references periodically.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to