[
https://issues.apache.org/jira/browse/HDFS-13106?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16354320#comment-16354320
]
Lei (Eddy) Xu commented on HDFS-13106:
--------------------------------------
Hi, [~billyean]
Thanks again for the updates. I have a few minor nits:
{code}
public ErasureCodingPolicy getEcPolicy()
{code}
It can be {{private}} or {{private static}}?
Please also make {{public static final Logger LOG }} to be {{private}}.
After every API call, please also using Junit assert to verify the changes are
made correctly in the filesystem, for example:
{code}
userFs.setOwner(p1, userName, groupName);
userFs.access(p1, FsAction.READ);
fs.setTimes(p1, System.currentTimeMillis() - 1000L,
System.currentTimeMillis() - 2000L);
{code}
* Please rename every test case function name to {{TestAccess / TestQuota}} and
etc.
* In {{exerciseAccess}} it also test against setOwner and setTime? You should
change the function name or split the test case.
* {{fail("truncate should not be supported.");}} could you rephrase that to be
something like "truncate is not supported on erasure coded file"?
Thanks.
> Need to exercise all HDFS APIs for EC
> -------------------------------------
>
> Key: HDFS-13106
> URL: https://issues.apache.org/jira/browse/HDFS-13106
> Project: Hadoop HDFS
> Issue Type: Test
> Components: hdfs
> Affects Versions: 3.0.0
> Reporter: Haibo Yan
> Assignee: Haibo Yan
> Priority: Major
> Attachments: HDFS-13106.001.patch, HDFS-13106.002.patch
>
>
> Exercise FileSystem API to make sure all APIs works as expected under Erasure
> Coding feature enabled
--
This message was sent by Atlassian JIRA
(v7.6.3#76005)
---------------------------------------------------------------------
To unsubscribe, e-mail: [email protected]
For additional commands, e-mail: [email protected]