[ 
https://issues.apache.org/jira/browse/HDFS-13251?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Xiaoyu Yao updated HDFS-13251:
------------------------------
    Description: 
There are a few unit tests that rely on hard-coded MiniDFSCluster data dir 
names.

 
 * TestDataNodeVolumeFailureToleration
 * TestDataNodeVolumeFailureReporting
 * TestDiskBalancerCommand
 * TestBlockStatsMXBean
 * TestDataNodeVolumeMetrics
 * TestDFSAdmin
 * TestDataNodeHotSwapVolumes
 * TestDataNodeVolumeFailure

This ticket is opened to use
{code:java}
MiniDFSCluster#getInstanceStorageDir(0, 1);

instead of like below

new File(cluster.getDataDirectory(), "data1");{code}
 

  was:
There are a few unit tests that rely on hard-coded MiniDFSCluster data dir 
names.

 
 * TestDataNodeVolumeFailureToleration
 * TestDataNodeVolumeFailureReporting
 * TestDiskBalancerCommand
 * TestBlockStatsMXBean
 * TestDataNodeVolumeMetrics
 * TestDFSAdmin
 * TestDataNodeHotSwapVolumes
 * TestDataNodeVolumeFailure

This ticket is opened to use

{code} MiniDFSCluster#getInstanceStorageDir() \{code} instead of 
new File(cluster.getDataDirectory(), "data1");


> Avoid using hard coded datanode data dirs in unit tests
> -------------------------------------------------------
>
>                 Key: HDFS-13251
>                 URL: https://issues.apache.org/jira/browse/HDFS-13251
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: test
>            Reporter: Xiaoyu Yao
>            Assignee: Ajay Kumar
>            Priority: Major
>
> There are a few unit tests that rely on hard-coded MiniDFSCluster data dir 
> names.
>  
>  * TestDataNodeVolumeFailureToleration
>  * TestDataNodeVolumeFailureReporting
>  * TestDiskBalancerCommand
>  * TestBlockStatsMXBean
>  * TestDataNodeVolumeMetrics
>  * TestDFSAdmin
>  * TestDataNodeHotSwapVolumes
>  * TestDataNodeVolumeFailure
> This ticket is opened to use
> {code:java}
> MiniDFSCluster#getInstanceStorageDir(0, 1);
> instead of like below
> new File(cluster.getDataDirectory(), "data1");{code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to