SammiChen commented on HDFS-11600:

Hi [~rakeshr], thanks for the comments.  I will upload a new patch to address 
all the issues. Regarding the class name with "P", you are right, it stands for 
"parameterized".   I was originally using the full word, then found out the 
class name becomes very very long, especially 

> Refactor TestDFSStripedOutputStreamWithFailure test classes
> -----------------------------------------------------------
>                 Key: HDFS-11600
>                 URL: https://issues.apache.org/jira/browse/HDFS-11600
>             Project: Hadoop HDFS
>          Issue Type: Improvement
>          Components: test
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Andrew Wang
>            Priority: Minor
>         Attachments: HDFS-11600-1.patch, HDFS-11600.002.patch, 
> HDFS-11600.003.patch, HDFS-11600.004.patch
> TestDFSStripedOutputStreamWithFailure has a great number of subclasses. The 
> tests are parameterized based on the name of these subclasses.
> Seems like we could parameterize these tests with JUnit and then not need all 
> these separate test classes.
> Another note, the tests will randomly return instead of running the test. 
> Using {{Assume}} instead would make it more clear in the test output that 
> these tests were skipped.

This message was sent by Atlassian JIRA

To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to