[
https://issues.apache.org/jira/browse/HDFS-2162?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13069870#comment-13069870
]
Konstantin Shvachko commented on HDFS-2162:
-------------------------------------------
I think this an unnecessary code change, which is induced by unnecessary
attempt to change current terminology.
> Merge NameNode roles into NodeType.
> -----------------------------------
>
> Key: HDFS-2162
> URL: https://issues.apache.org/jira/browse/HDFS-2162
> Project: Hadoop HDFS
> Issue Type: Sub-task
> Components: name-node
> Affects Versions: 0.23.0
> Reporter: Suresh Srinivas
> Assignee: Suresh Srinivas
> Priority: Minor
>
> Currently Namenode has {{NamenodeRole}} with roles NAMENODE, BACKUP and
> CHECKPOINT. {{NodeType}} has node types NAME_NODE and DATA_NODE. Merge
> NamenodeRole into NodeType.
--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira