[ 
https://issues.apache.org/jira/browse/HDFS-14179?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16731403#comment-16731403
 ] 

Íñigo Goiri commented on HDFS-14179:
------------------------------------

Can we also use logger style? Even though there's a guard, it is easier to read 
with the {} format.

> BlockReaderRemote#readNextPacket() should log the waiting time for packet 
> read.
> -------------------------------------------------------------------------------
>
>                 Key: HDFS-14179
>                 URL: https://issues.apache.org/jira/browse/HDFS-14179
>             Project: Hadoop HDFS
>          Issue Type: Bug
>          Components: hdfs-client
>    Affects Versions: 3.0.0
>            Reporter: Surendra Singh Lilhore
>            Assignee: Shubham Dewan
>            Priority: Major
>              Labels: newbie
>         Attachments: HDFS-14179.001.patch
>
>
> Sometime read is reported very slow due to disk or some other reason. 
> {{BlockReaderRemote#readNextPacket()}} should print the datanode IP and 
> waiting time in trace log.
> {code:java}
> //Read packet headers.
> packetReceiver.receiveNextPacket(in);
> PacketHeader curHeader = packetReceiver.getHeader();
> curDataSlice = packetReceiver.getDataSlice();
> assert curDataSlice.capacity() == curHeader.getDataLen();
> LOG.trace("DFSClient readNextPacket got header {}", curHeader);{code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

---------------------------------------------------------------------
To unsubscribe, e-mail: hdfs-issues-unsubscr...@hadoop.apache.org
For additional commands, e-mail: hdfs-issues-h...@hadoop.apache.org

Reply via email to