Hi Neil,

Neil Mather <n...@doubleloop.net> skribis:

> I get the following errors right at the end of the installation process:
> error: 
> '/gnu/store/dzr35fc1wvgkgz2d4qp3xzhn6wg313c-grub-efi-2.02/sbin/grub-install 
> --boot-directory=/mnt/boot --bootloader-id=Guix --efi-directory=/boot/efi' 
> exited with status 1; output follows:
> Installing for x86_64-efi platform.
> /gnu/store/dzr35fc1wvgkgz2d4qp3xzhn6wg313c-grub-efi-2.02/sbin/grub-install: 
> error: failed to get canonical path of '/boot/efi'.
> guix system: error: failed to install bootloader 
> /gnu/store/kcimndl2hncnng4vhyylipabdxk7f0r9-bootloader-installer
> This is using the guided graphical installer, with the option to use the full 
> disk.  I didn't change anything from the installer's suggested partition 
> layout.
> The machine does support EFI.
> Out of interest, I tried installing via legacy BIOS, and that worked OK.

The relevant code in GRUB is:

--8<---------------cut here---------------start------------->8---
    char * t = grub_util_path_concat (2, bootdir, GRUB_DIR_NAME);
    grub_install_mkdir_p (t);
    grubdir = grub_canonicalize_file_name (t);
    if (!grubdir)
      grub_util_error (_("failed to get canonical path of `%s'"), t);
    free (t);
--8<---------------cut here---------------end--------------->8---

I believe the only way this can fail is if ‘grub-install’ fails to
create /boot/efi on the target device for some reason.

Could it be that the target device was (re)mounted read-only or was
full?  Did /var/log/messages in the installer show any hints?

Thanks for reporting the issue,

Reply via email to