On Wed, Mar 7, 2018 at 6:59 PM Sanne Grinovero <sa...@hibernate.org> wrote:

> Hi all,
> good news on the backwards compatibility; David suggested we could use
> his "bridger" tool to have the Session API binary compatible with
> older versions.
>  - https://github.com/dmlloyd/bridger

Wow, very cool!  Thanks for the tool David!

I had more trouble testing it.
> Here a failed approach: I could not get Gradle to compile with a
> different version used for testing, while at the same time not driving
> dependencies in my IDE nuts :)
>  -
> https://github.com/Sanne/hibernate-orm/commit/28f5110cf9ccee9614bceb454036d5204cf9ff6f
You mean compile tests using the current project version but run tests
against an older version?  If so, by far the easiest option will be a
separate sourceSet.  Here you can use the project dependency in testCompile
and the older version in testRuntime.

If that's not what you mean, can you explain some more?
hibernate-dev mailing list

Reply via email to