I've added support for stuff like:

  <property name="foo" optimistic-lock="false"/>

  <set name="foos" optimistic-lock="false">
       ...
  </set>

This lets you have a property which does not participate in optimistic
locking, or a collection that does not cause an increment of its
owners version number when it changes.

Have I called it the right thing? I thought of "versioned" as the
attribute name, but rejected that since it also applies to non-
version based optimistic locking. How about "lock"? Or
something?



-------------------------------------------------------
This SF.Net email is sponsored by BEA Weblogic Workshop
FREE Java Enterprise J2EE developer tools!
Get your free copy of BEA WebLogic Workshop 8.1 today.
http://ads.osdn.com/?ad_id=5047&alloc_id=10808&op=click
_______________________________________________
hibernate-devel mailing list
[EMAIL PROTECTED]
https://lists.sourceforge.net/lists/listinfo/hibernate-devel

Reply via email to