What I'm getting at is that adding new keywords should only be added when it's absolutely necessary. New keywords can break upward compatibility and make it difficult to extend the language later.

Joshua Davis wrote:

upper(x) and lower(x) should be handled by the 'method' syntax and semantic actions, no?

Did you add current_date, current_time, and current_timestamp as keywords, or as specially interpreted identifiers (i.e. semantic actions only)?

Gavin King wrote:

Last night I wrote some code which I was kinda
proud of at the time (I proved I could add new
functionality to the query parser all by myself),
but now I'm not so sure that my approach was Good.

Basically, I added the builtin functions to the
grammar - stuff like this:

 lower(x)
 upper(x)
 current_date
 current_time
 current_timestamp

with the idea that they would be translated to the
appropriate construct for the platform. (Got it
working for all clauses, including select clause.)

But after that, I thought that maybe you guys would
prefer if we handled all this as an ordinary
function form, and recognize the builtins in java
code.

Looking for some guidance....





-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel





-------------------------------------------------------
The SF.Net email is sponsored by: Beat the post-holiday blues
Get a FREE limited edition SourceForge.net t-shirt from ThinkGeek.
It's fun and FREE -- well, almost....http://www.thinkgeek.com/sfshirt
_______________________________________________
hibernate-devel mailing list
hibernate-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/hibernate-devel

Reply via email to