Arthur Bogaart pushed to branch feature/CHANNELMGR-1747 at cms-community / 
hippo-addon-channel-manager


Commits:
ae7f27d6 by Arthur Bogaart at 2018-03-02T11:46:27+01:00
CHANNELMGR-1747 Restrict to node >= 8 and npm >= 5

- - - - -
c95aa942 by Arthur Bogaart at 2018-03-02T12:00:23+01:00
CHANNELMGR-1747 Upgrade angularjs-api module to node8 & npm5

- - - - -
b640f0de by Arthur Bogaart at 2018-03-02T12:09:19+01:00
CHANNELMGR-1747 Use registry.npmjs.org

- - - - -
f023e16e by Arthur Bogaart at 2018-03-02T12:10:09+01:00
CHANNELMGR-1747 Enforce node >= 8 & npm >= 5 for angularjs-api

- - - - -
faabc100 by Arthur Bogaart at 2018-03-02T12:16:55+01:00
CHANNELMGR-1747 Remove unused version property

- - - - -


5 changed files:

- angularjs-api/.npmrc
- angularjs-api/npm-shrinkwrap.json
- angularjs-api/package.json
- frontend/npm-shrinkwrap.json
- frontend/package.json


Changes:

=====================================
angularjs-api/.npmrc
=====================================
--- a/angularjs-api/.npmrc
+++ b/angularjs-api/.npmrc
@@ -1,2 +1,2 @@
 engine-strict=true
-registry=https://maven.onehippo.com/npm-all/
+registry=https://registry.npmjs.org


=====================================
angularjs-api/npm-shrinkwrap.json
=====================================
The diff for this file was not included because it is too large.

=====================================
angularjs-api/package.json
=====================================
--- a/angularjs-api/package.json
+++ b/angularjs-api/package.json
@@ -1,6 +1,5 @@
 {
   "name": "hippo-addon-channel-manager-angularjs-api",
-  "version": "3.2.2-SNAPSHOT",
   "private": true,
   "scripts": {
     "grunt": "grunt",
@@ -8,6 +7,10 @@
     "start": "grunt server",
     "test": "grunt test"
   },
+  "engines": {
+    "node": ">=8",
+    "npm": ">=5"
+  },
   "dependencies": {
     "angular": "1.4.8",
     "jquery": "2.1.4"
@@ -29,7 +32,7 @@
     "jasmine-core": "2.4.1",
     "jasmine-jquery": "2.1.1",
     "jshint-stylish": "2.1.0",
-    "karma": "1.1.1",
+    "karma": "2.0.0",
     "karma-jasmine": "0.3.6",
     "karma-junit-reporter": "0.3.8",
     "karma-phantomjs-launcher": "0.2.3",


=====================================
frontend/npm-shrinkwrap.json
=====================================
The diff for this file was not included because it is too large.

=====================================
frontend/package.json
=====================================
--- a/frontend/package.json
+++ b/frontend/package.json
@@ -6,6 +6,10 @@
     "start": "grunt server",
     "test": "grunt test"
   },
+  "engines": {
+    "node": ">=8",
+    "npm": ">=5"
+  },
   "dependencies": {
     "@bloomreach/hippo-theme": "2.2.3",
     "angular": "1.4.8",



View it on GitLab: 
https://code.onehippo.org/cms-community/hippo-addon-channel-manager/compare/e297e6b2343ae007ae71acb46239765985c6e332...faabc100a18f663f909cd37672423bdc5c3cff40

---
View it on GitLab: 
https://code.onehippo.org/cms-community/hippo-addon-channel-manager/compare/e297e6b2343ae007ae71acb46239765985c6e332...faabc100a18f663f909cd37672423bdc5c3cff40
You're receiving this email because of your account on code.onehippo.org.
_______________________________________________
Hippocms-svn mailing list
Hippocms-svn@lists.onehippo.org
https://lists.onehippo.org/mailman/listinfo/hippocms-svn

Reply via email to