[ https://issues.apache.org/jira/browse/HIVE-1016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12904377#action_12904377 ]
HBase Review Board commented on HIVE-1016: ------------------------------------------ Message from: "Carl Steinbach" <c...@cloudera.com> ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: http://review.cloudera.org/r/748/ ----------------------------------------------------------- Review request for Hive Developers. Summary ------- This patch adds UDFContext, a singleton class that provides UDFs with runtime access to the JobConf. This patch borrows heavily from PIG-1085. This addresses bug HIVE-1016. http://issues.apache.org/jira/browse/HIVE-1016 Diffs ----- ql/src/java/org/apache/hadoop/hive/ql/exec/ExecMapper.java c257217 ql/src/java/org/apache/hadoop/hive/ql/exec/ExecReducer.java 3d7c798 ql/src/java/org/apache/hadoop/hive/ql/exec/UDFContext.java PRE-CREATION ql/src/test/org/apache/hadoop/hive/ql/udf/UDFGetConfProp.java PRE-CREATION ql/src/test/queries/clientpositive/udf_testcontext.q PRE-CREATION ql/src/test/results/clientpositive/udf_testcontext.q.out PRE-CREATION Diff: http://review.cloudera.org/r/748/diff Testing ------- Thanks, Carl > Ability to access DistributedCache from UDFs > -------------------------------------------- > > Key: HIVE-1016 > URL: https://issues.apache.org/jira/browse/HIVE-1016 > Project: Hadoop Hive > Issue Type: New Feature > Components: Query Processor > Reporter: Carl Steinbach > Assignee: Carl Steinbach > Attachments: HIVE-1016.1.patch.txt > > > There have been several requests on the mailing list for > information about how to access the DistributedCache from UDFs, e.g.: > http://www.mail-archive.com/hive-u...@hadoop.apache.org/msg01650.html > http://www.mail-archive.com/hive-u...@hadoop.apache.org/msg01926.html > While responses to these emails suggested several workarounds, the only > correct > way of accessing the distributed cache is via the static methods of Hadoop's > DistributedCache class, and all of these methods require that the JobConf be > passed > in as a parameter. Hence, giving UDFs access to the distributed cache > reduces to giving UDFs access to the JobConf. > I propose the following changes to GenericUDF/UDAF/UDTF: > * Add an exec_init(Configuration conf) method that is called during Operator > initialization at runtime. > * Change the name of the "initialize" method to "compile_init" to make it > clear that this method is called at compile-time. -- This message is automatically generated by JIRA. - You can reply to this email to add a comment to the issue online.