hi matt, yeah i relaized the form, but putting it prior /form gives me that:

mixed parameter tags and non-parameter tags (did you forget a ':'?) --
at app/views/taglibs/auto/rapid/pages.dryml:86

and yes, im just experimenting with the whole thing. lather it should
be outsourced...
thx



On Fri, Oct 30, 2009 at 4:39 PM, Matt Jones <[email protected]> wrote:

>
>
> On Oct 30, 2009, at 4:26 PM, tom wrote:
>
> > thx matt,
> >
> > i looked into the input-many tag and yes it look slike as what i need:
> > http://cookbook.hobocentral.net/api_tag_defs/input-many
> >
> > so i tried this (pages):
> > <def tag="new-page" for="CountSheetHeader">
> >   <page merge title="New Count Sheet Header">
> >     <body: class="new-page count-sheet-header" param/>
> >
> >     <content: param>
> >       <section param="content-header">
> >         <h2 param="heading">New Count Sheet Header</h2>
> >       </section>
> >
> >       <section param="content-body">
> >         <form param>
> >           <submit: label="Create Count Sheet Header"/>
> >         </form>
> >       </section>
> > <input-many:count_sheet_lines><field-list fields="qty1, qty2, note"/
> > ></input-many>
> >     </content:>
> >   </page>
> > </def>
> >
> > this gives me the ajax functionality to add / remove the lines,
> > showing me 3 fields but there are NO text-input fields....
> > any ideas?
> > thx
>
> Couple things:
>
> - input-many belongs inside a form. Things won't work quite right
> without it...
> - what user are you logged in as? The default permissions are
> typically all set to current_user.administrator?, so if you're not an
> admin things won't work unless you've changed the permissions.
> "Vanishing fields" are a classic symptom of a permissions issue.
>
> Some quick style tips:
> - underscores are better avoided in tag names; it's not incorrect
> syntax, but it breaks up the XML-look of the thing. Hobo will convert
> dashed names to underscore.
> - especially at first, you may want to avoid getting tangled up in tag
> definitions. There are some good uses for it, but if you'll only ever
> be calling this page from the same place, you'll have an easier time
> just dropping a regular dryml page into app/views/count_sheet_headers/
> new.dryml. It also makes things easier to follow in source control, as
> you're not just making a zillion changes to application.dryml.
>
> --Matt Jones
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups "Hobo 
Users" group.
To post to this group, send email to [email protected]
To unsubscribe from this group, send email to 
[email protected]
For more options, visit this group at 
http://groups.google.com/group/hobousers?hl=en
-~----------~----~----~----~------~----~------~--~---

Reply via email to