The Network Configuration (netconf) WG in the Operations and Management Area of the IETF is undergoing rechartering. The IESG has not made any determination yet. The following draft charter was submitted, and is provided for informational purposes only. Please send your comments to the IESG mailing list ([email protected]) by 2026-09-27.
Network Configuration (netconf) ----------------------------------------------------------------------- Current status: Active WG Chairs: Kent Watsen <[email protected]> Per Andersson <[email protected]> Secretaries: Fan Zhang <[email protected]> Assigned Area Director: Mahesh Jethanandani <[email protected]> Operations and Management Area Directors: Mahesh Jethanandani <[email protected]> Mohamed Boucadair <[email protected]> Mailing list: Address: [email protected] To subscribe: https://www.ietf.org/mailman/listinfo/netconf Archive: https://mailarchive.ietf.org/arch/browse/netconf/ Group page: https://datatracker.ietf.org/group/netconf/ Charter: https://datatracker.ietf.org/doc/charter-ietf-netconf/ The NETwork CONFiguration (NETCONF) Working Group, is responsible for the development and maintenance of protocols such as NETCONF and RESTCONF for YANG data model-driven management (for the purposes of, for example, configuration, monitoring, telemetry, and zero-touch), their transport mappings and encodings, defining data models necessary to support the protocols, and defining mechanisms supporting the operational deployment of systems using the protocols. YANG (RFC 7950) is the recommended NETCONF and RESTCONF data modeling language, which introduces advanced language features for configuration management. The NETCONF and RESTCONF protocols transport YANG-modeled data over the wire. The NETCONF working group should ensure that relevant updates to the NETCONF and RESTCONF protocols are evaluated for consistency and compatibility between the two. The NETCONF WG is currently responsible for the following standards: a) The network management protocol NETCONF (RFC 6241). This effort entails periodically updating the NETCONF-related specifications to address new requirements as they arise. b) The network management protocol RESTCONF (RFC 8040). This effort entails periodically updating the RESTCONF-related specifications to address new requirements as they arise. c) The transport mappings and encodings used by the data model-driven protocols. d) The data models and mechanisms related to network management protocols. Specifically, data models enabling the configuration and/or monitoring of the protocols themselves. e) The data models for subscriptions to data, and protocol bindings for pushing subscribed data to clients, for the purpose of monitoring and telemetry. f) The mechanisms enabling devices' zero-touch provisioning and the related call home functions. The NETCONF working group consults with the NETMOD working group to ensure that new requirements are understood and can be met by the YANG data modeling language (RFC 7950) developed within that working group. Milestones: Dec 2026 - Submit to IESG for publication: drafts regarding List Pagination as Proposed Standard Dec 2026 - Submit to IESG for publication: drafts enhancing YANG-Push as Proposed Standard _______________________________________________ IETF-Announce mailing list -- [email protected] To unsubscribe send an email to [email protected]
