The Artemis log file that you sent opens and runs its fit to completion in a 
reasonable way on the Windows 7 machine here at my beamline.

As you no doubt saw, the message in the log fle is "Out of memory".

I suspect that this gives a hint about the problem.  One of the shortcomings of 
the current software is that it is based on Ifeffit, a library of exafs-related 
routines which is written in Fortran and which is related to code that Matt 
wrote way back (in some previous century) when he and I were in grad school.  
One of the problems with the dialect of Fortran that Ifeffit is written in is 
that it does not have dynamic memory allocation.  This means that Ifeffit is 
not able to request memory from the operating system as needed.  Instead, it 
requests a rather large block of memory at start-up and holds it in reserve in 
case it is needed.  Eventually, it will run out of memory.  If you search the 
mailing list, you will find many example of problems related to people 
attempting to load many dozens of data sets into Athena and eventually 
exhausting Ifeffit's memory store.

If your computer has rather little on-board memory, or if you are running lots 
of other memory-intensive program, or if you are running several instances of 
Ifeffit, you may exhaust your computer's capacity.  Because of the "out of 
memory" message in the log file, I suspect that is what is happening to you.

The very long time that it took Artemis to give up the ghost and die, suggests 
that large amounts of memory were being swapped to disk as Ifeffit was trying 
to start and then trying to fail because memory had been exhausted.

Do you think you are in one of those situations?  Do you observe this behavior 
on another computer?  (I suspect not, because your project file runs just fine 
on my computer here at my beamline.)  Do you observe this behavior if you 
manually halt all the other things running on your computer?  Or right after 
rebooting (when, presumably, lots of other stuff isn't running)?


PS: Among the many advantages to Matt's Larch project, which will eventually 
replace Ifeffit in my software and elsewhere, is that it is written in a way 
that does dynamic memory allocation.

[] on behalf of Matthias Filez 
Sent: Wednesday, January 16, 2013 5:32 AM
To: 'XAFS Analysis using Ifeffit'
Subject: Re: [Ifeffit] (D)Artemis and (D)Athena crash - perl not responding


I looked inside the dartemis.log file before, but nothing was inside. Sorry
for not mentioning that! Now, I waited for 20 minutes during the startup of
(D)Artemis and the software seemed to work. I opened a project file (see
attachment), but then Artemis gets stuck again. This time, a bug report
could be obtained (see attachment).

Laboratory for Chemical Technology
Department of Chemical Engineering, Ghent University
Krijgslaan 281 S5, B-9000 Ghent, Belgium

-----Original Message-----
[] On Behalf Of Ravel, Bruce
Sent: dinsdag 15 januari 2013 18:03
To: XAFS Analysis using Ifeffit
Subject: Re: [Ifeffit] (D)Artemis and (D)Athena crash - perl not responding

As I have said many, many times before, there's not much I can do without a
proper bug report.


[] on behalf of Matthias Filez
Sent: Tuesday, January 15, 2013 11:52 AM
Subject: [Ifeffit] (D)Artemis and (D)Athena crash - perl not responding

Dear all,
Several days ago, I was using (D)Artemis of the Demeter with Strawberry Perl
package version on a Windows 7 64-bit Operating System. Suddenly,
the software crashed when opening (D)Artemis. Ever since, (D)Artemis and
(D)Athena do not respond anymore when I open them. The windows pop up, but
the buttons inside the window do not appear anymore and the software gets
stuck. When trying to check for a solution, "perl.exe does not respond" is
given as a comment. (D)Hephaestos works fine. (D)Atoms functions until I
load an .inp file, then it gets stuck too.
I already tried to reinstall and to update to the newest version (9.14), but
nothing helps. I tried to install Strawberry Perl's newest version, but
since the necessary modules are included in the Demeter software this is
probably useless. Does someone know what to do?
Thanks a lot,
Matthias Filez
Ir. Matthias Filez
Laboratory for Chemical Technology
Department of Chemical Engineering, Ghent University Krijgslaan 281 S5,
B-9000 Ghent, Belgium

Ifeffit mailing list

Ifeffit mailing list

Reply via email to