Installing 0.9.19 overtop of and Athena works fine.

Installing 0.9.19 clean (deleting demeter directory under appdata/roaming)
2nd attempt to open file in DAthena results in only 1 mini-graph.

Ranges are 0 for Emin/max, kmin/max, Rmin/max - putting a valid range restores full graph e.g. Rmin = 0 , Rmax = 6 gives full-size R-space graph...ditto for fixing other ranges. Fixed 3 out of 4 and read in a new file...obtained 3 mini-graphs...reset q range
as well and that one appears too.

Exited. Restarted. Read in file -
Show Command Buffer/Plot Buffer
## energy quadrant
set title "{/*1.6 Energy}"
set xlabel "{/*1.4 Energy&{aa}(eV)}"
set ylabel "{/*1.4 x{/Symbol m}(E)}"
#set xrange [ 11870.11617648 : 11870.11617648 ]
plot 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_vlxtfjcm' using 1:2 with lines ls 2,\ 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_tfoziltm' using 1:2 with lines ls 1,\ 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_fthredqy' using 1:2 with lines ls 3,\ 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_iebbuian' using 1:2 with lines ls 4

## k quadrant
set title "{/*1.5 k-space}"
set xlabel "{/*1.2 Wavenumber&{aa}({\305}^{-1})}"
set ylabel "{/*1.2 k^{2} {\267} {/Symbol c}(k)&{aa}({\305}^{-2})}"
set xrange [ 0 : 0 ]
plot 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_xizghpwm' using 1:2 with lines ls 1

## R quadrant
set title "{/*1.5 R-space}"
set xlabel "{/*1.2 Radial distance&{aa}({\305})}"
set ylabel "{/*1.2 {/*1.25 |}{/Symbol c}(R){/*1.25 |}&{aa}({\305}^{-3})}"
set xrange [ 0 : 0 ]
plot 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_nwtxpqxm' using 1:2 with lines ls 1,\ 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_vysurgrh' using 1:2 with lines ls 2

## q quadrant
set title "{/*1.5 q-space}"
set xlabel "{/*1.2 Wavenumber&{aa}({\305}^{-1})}"
set ylabel "{/*1.2 {/*1.25 Re[}{/Symbol c}(q){/*1.25 ]}&{aa}({\305}^{-2})}"
set xrange [ 0 : 0 ]
plot 'C:\Users\ragordon\AppData\Roaming\demeter\stash\gp_hxroumyr' using 1:2 with lines ls 1

unset multiplot

So, seems to be setting the xranges to zero for a clean install these plots, and gnuplot doesn't plot if no xrange. If I reset, then I can move around and use DAthena 9.19
without issue...DArtemis is still an unhappy DHuntress with fpj files...

On 1/14/2014 3:28 PM, Bruce Ravel wrote:
On 01/14/2014 04:11 PM, Robert Gordon wrote:
Hi Matt, Shoaib (and Bruce lurking in the luminiferous ether),

I have 8.1 x64 on my laptop and just upgraded to 0.9.19 - clean install.
I can offer some additional details on this problem.

I read in a file in DAthena, extracted the chi(k) and saved the project.
All buttons worked. When the file was read in, 4 mini-graphs displayed,
and I could select k, E, R as desired for full graph.

The second time I run it, reading in the exact same file, only the
energy mini-graph
displays and the E,k and R buttons no longer produce any graphs.

 From the clean install, I saved the DAthena.prj. I started DArtemis,
read in the DAthena.prj
file, haven't tried fitting but saved the DArtemis fpj file.
If I try re-opening the fpj file I just saved in DArtemis, DArtemis
but re-opening the DAthena prj file after starting DArtemis is not a

In DAthena, if I go to the appdata/roaming/demeter directory and delete
the demeter.ini file,
DAthena will display all 4 mini-graphs when I open the prj file and the
k,R,E buttons work.


If you are inclined to help me with some troubleshooting, I have a request.

If you can recreate the situation where only the energy part of the
quad plot is displayed and the plot buttons stop working, could you
tell me a couple things:

  1. What are the values for the plotting ranges in E, k, R, and q?
     The reason I ask is that I stumbled upon a situation where Emin,
     Emax, kmin, etc all got set to zero (as did a bunch of other
     parameters).  I could not figure out how to reproduce that
     problem, but it would be helpful to know if it happened to
     someone else.

  2. In the Monitor menu, click on "Show command buffer".  In the
     "Plot buffer" at the bottom of the window scroll up just a little
     bit to where you'll see lines that say things like

plot '/home/bruce/.horae/stash/gp_vdnzxmxl' using 1:2 with lines ls 1,\ '/home/bruce/.horae/stash/gp_wfaastqg' using 1:2 with lines ls 2

     What I want to know is if the 8 random characters after
     "stash/gp_" are the same or different (as in my example here).

In short, I want to know if you have seen some problems I have
observed by not been able to reproduce.

0.9.19 does not appear to be one of my better packaging efforts, alas.


I uninstalled and went back to DAthena seems to work - all 4
mini-graphs, and E,k,R work.
DArtemis still opens, reads DAthena.prj but crashes when trying to read
fpj file created under

Going back to the last 0.8.0nn versions, no crashes from Artemis or Athena.

Hope this helps.


On 1/14/2014 12:38 PM, Matt Newville wrote:
Hi Shoaib,

On Tue, Jan 14, 2014 at 10:46 AM, Shoaib Muhammad
<> wrote:

I have recently upgraded my computer to Windows 8.1 Pro x64 and after
upgrade I can’t run Athena and Artemis. The problem symptoms are:

1-      If I use Demeter version 0.9.13, Athena opens but when I try
to open
previously saved file, Athena simply crashes without showing any error.
Artemis also shows similar behavior.

2-      By using latest build Demeter 0.9.19, Athena behavior is
different it opens the files and show the plot. But pressing the E,k,R
buttons does not change the plot. Artemis still crashes by opening any
project file without any error.

I have tried following things, installed in compatibility mode of
Athena worked fine only once after installing in compatibility mode.

Installed in different drives but situations remains the same. Tried
to “run
as Admin” but no improvement.

Installed Demeter on three different computers running Windows 8.1
x64 but
similar behavior is received.

Kindly suggest me some work around because I have to use Demeter on
daily basis. I have attached log file obtained from Demeter 0.9.13
under Window 8.1 x64.


Shoaib Muhammad

Department of Energy Science

Sungkyunkwan University

South Korea

Ifeffit mailing list

I think you might be in mostly uncharted waters with 64-bit Windows 8.
  I have access to many Windows machines, but I don't know of any
64-bit Windows 8.1 machines in our group.

If you're up for it, it might be worth installing demeter from source
from the github repository, following
and asking for help if you get stuck.

I'm sure it would be a great help to others if you did this....


Ifeffit mailing list

Dr. Robert Gordon
Staff Scientist, PNCSRF
APS Sector 20 (PNC/XSD)
9700 S Cass Ave. 435E
Argonne, IL, USA  60439

630-252-0580 fax

Ifeffit mailing list

Reply via email to