Hi,

I emailed relatively recently about Artemis crashing on my MacBook Pro. This is 
the email i sent:

'I was using Artemis on Mac and it crashed. Now when i try to reopen Artemis it 
attempts restore what i was doing from an autosave file but it becomes 
unresponsive and is just stuck on the screen posted below. Does anyone know how 
i can fix it? Do i have to uninstall and then reinstall the software? i have 
left it running for over an hour but it still hasn’t worked.

Thanks for any help’

Now the exact same thing is occurring with Athena. One of the replies from the 
previous email instructed me to remove parts of the programme code. I did so an 
Artemis worked perfectly after, i just needed to save often. The full email 
that instructed me on this can be found below:

Hi Daniel,
 
I had a similar issue, but my solution hasn’t been put up yet on the list:
 
With respect to the error that Katherine Davies reported (02/16/2016; RE: 
[Ifeffit] problem with Artemis crashing on mac), I came across the same problem 
when running Artemis on Mac. I believe this issue is caused by a piece of code 
found in “artemis.pm” (Demeter/UI/artemis.pm) line 512-521:
 
512         sub process_argv {
513          my ($app, @args) = @_;
514             if (Demeter->co->default("artemis", "autosave") and 
autosave_exists()) {
515               import_autosave();
516         } elsif ($args[0]) { # and -e $args[0]) {
517            my $file = File::Spec->rel2abs( $args[0] );
518            read_project(\%frames, $file) if Demeter->is_zipproj($file, 0, 
'fpj');
519             };
520         };
 
I think the error is due to not shutting down the program correctly causing 
this code to fail. A fix is to comment out lines 514-516 & 519, save the file 
and reboot Artemis (to edit artemis.pm you will need to make the file 
writable)– thus getting you past startup and allowing you to turn off the 
autosave settings from within Artemis as suggested. Put the code back as it was 
after you have finished. Hope this helps.
 
Best,
 
Luke Higgins

I tried searching for similar code in the Athena programme but couldn’t find 
it. Does anyone have a similar solution, or any solution, to this problem?

Thank you so much 
_______________________________________________
Ifeffit mailing list
Ifeffit@millenia.cars.aps.anl.gov
http://millenia.cars.aps.anl.gov/mailman/listinfo/ifeffit
Unsubscribe: http://millenia.cars.aps.anl.gov/mailman/options/ifeffit

Reply via email to