Dear igraph staff,

I'am Greta, a PhD student. I'm trying to install igraph on Rstudio but I have 
several errors in the log during the installation. I tried to install the most 
recent version of igraph through install.packages("igraph") but I obtain this 
foreign-graphml.c: In function ‘igraph_write_graph_graphml’:
foreign-graphml.c:1408:46: error: expected ‘)’ before ‘GRAPHML_NAMESPACE_URI’
ret=fprintf(outstream, "<graphml xmlns=\"" GRAPHML_NAMESPACE_URI "\"\n");
foreign-graphml.c:1412:59: error: expected ‘)’ before ‘GRAPHML_NAMESPACE_URI’
ret=fprintf(outstream, " xsi:schemaLocation=\"" GRAPHML_NAMESPACE_URI "\n");
foreign-graphml.c:1414:38: error: expected ‘)’ before ‘GRAPHML_NAMESPACE_URI’
ret=fprintf(outstream, " " GRAPHML_NAMESPACE_URI "/1.0/graphml.xsd\">\n");
/usr/lib/R/etc/Makeconf:159: recipe for target 'foreign-graphml.o' failed
make: *** [foreign-graphml.o] Error 1
ERROR: compilation failed for package ‘igraph’
* removing ‘/home/gromano/R/x86_64-pc-linux-gnu-library/3.4/igraph’
Installation failed: Command failed (1)

Then I also tried to install an older version (1.1.1) but nothing changes.
Can you help me please?
Thank you

Greta Romano
Sent from Mailspring 
 the best free email app for work
igraph-help mailing list

Reply via email to