I tried to pull AWS metrics through cloudwatch using telegraf and write the 
output data into influxdb.

When I run the test with sample config, it shows only EC2 stats . Not 
showing anything else.

For example, 
If I set the namespace to "AWS/EC2", then run the below command,

]# telegraf -config telegraf.conf -input-filter cloudwatch -test
>cloudwatch_aws_ec2,host=gugan.ipt.local,region=us-east-1,unit=percent 
cpu_utilization_average=0.08,cpu_utilization_maximum=0.16,cpu_utilization_minimum=0,cpu_utilization_sample_count=2,cpu_utilization_sum=0.16
 
1476251580000000000
> 
cloudwatch_aws_ec2,host=gugan.ipt.local,image_id=ami-c481fad3,region=us-east-1,unit=bytes
 
disk_write_bytes_average=0,disk_write_bytes_maximum=0,disk_write_bytes_minimum=0,disk_write_bytes_sample_count=2,disk_write_bytes_sum=0
 
1476251580000000000


If I changed namespace to EBS, it not showing any output
[root@gugan ~]# telegraf -config telegraf.conf -input-filter cloudwatch 
-test
* Plugin: cloudwatch, Collection 1
* Internal: 1m0s
[root@gugan ~]

Should I need to do any changes in AWS or else in Telegraf configuration ?.

-- 
Remember to include the version number!
--- 
You received this message because you are subscribed to the Google Groups 
"InfluxData" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to influxdb+unsubscr...@googlegroups.com.
To post to this group, send email to influxdb@googlegroups.com.
Visit this group at https://groups.google.com/group/influxdb.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/influxdb/921aca11-d47a-48c9-bbfa-8eeace51e122%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to