I've used Gnus for some number of years, pulling email via POP3 while
leaving it on the server. I've done this from gmail for at least 5 years, I

Not too long ago, I moved from Debian Wheezy to Jessie, and it stopped
working.  I was busy and didn't work on it for a while, but I just tried
again, found that I couldn't log into gmail because I lacked an app
password, and apparently fixed it.

I entered `3 g` and waited while gnus grabbed a few months of email.  Then
it said it was moving them, as it should with nnsplit.  Finally, it gave me
an error: `gnus-get-unread-articles: Wrong type argument: numberp, y`

I ran (setq debug-on-error t) in the scratch buffer and restarted Gnus.  It
did the same thing, and then I ended up with this in a backtrace buffer:

Debugger entered--Lisp error: (wrong-type-argument numberp y)
  gnus-get-unread-articles(nil nil)
  gnus-setup-news(nil nil nil)
  byte-code(" \204 \204 \306 \210\202L\307\310!\210\311\n! \f\204
\203!\312 \210\313\314 #\210\307\315!\210 \2036\316\317\320\"\210\321
\210\322 !\210\323 \210\324\325!\210\326 \210\307\327!\210\314\207"
[dont-connect did-connect gnus-startup-file gnus-current-startup-file
gnus-slave gnus-use-dribble-file gnus-group-quit gnus-run-hooks
gnus-startup-hook gnus-make-newsrc-file gnus-dribble-read-file
gnus-setup-news nil gnus-setup-news-hook gnus-request-create-group "queue"
(nndraft "") gnus-start-draft-setup gnus-group-list-groups
gnus-group-first-unread-group gnus-configure-windows group
gnus-group-set-mode-line gnus-started-hook level gnus-agent] 4)
  gnus-1(nil nil nil)
  call-interactively(gnus record nil)
  command-execute(gnus record)
  execute-extended-command(nil "gnus")
  call-interactively(execute-extended-command nil nil)

Does this make any sense to anyone?  Anything else I should look at to
figure this out?

I'm running Gnus v5.13 on Emacs 24.4.1.


info-gnus-english mailing list

Reply via email to