On Fri, Oct 14, 2016 at 8:44 AM, Roman Mohr <rm...@redhat.com> wrote:

> Hi,
>
> I saw a lot of failing builds lately on this job:
>
>   http://jenkins.ovirt.org/job/ovirt-engine_master_upgrade-
> from-3.6_el7_created/
>
> One log which still exists is:
>
> http://jenkins.ovirt.org/job/ovirt-engine_master_upgrade-
> from-3.6_el7_created/3666/
> It seems like the BUILD ENGINE RPM step is failing, but I can't see any
> reason why:
>
> BUILDING ENGINE RPM
> + create_rpms 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo/ovirt-engine-4.1.0-0.0.master.20161014001903.el7.centos.src.rpm
>  
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo
>  .gitee47dd2
> + local 
> src_rpm=/home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo/ovirt-engine-4.1.0-0.0.master.20161014001903.el7.centos.src.rpm
> + local 
> dst_dir=/home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo
> + local release=.gitee47dd2
> + local 
> workspace=/home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created
> + local 'BUILD_JAVA_OPTS_MAVEN=    -XX:MaxPermSize=1G     
> -Dgwt.compiler.localWorkers=1 '
> + local 'BUILD_JAVA_OPTS_GWT=    -XX:PermSize=512M     -XX:MaxPermSize=1G     
> -Xms1G     -Xmx6G '
> + env 'BUILD_JAVA_OPTS_MAVEN=    -XX:MaxPermSize=1G     
> -Dgwt.compiler.localWorkers=1 ' 'BUILD_JAVA_OPTS_GWT=    -XX:PermSize=512M    
>  -XX:MaxPermSize=1G     -Xms1G     -Xmx6G ' rpmbuild -D 'ovirt_build_minimal 
> 1' -D 'release_suffix .gitee47dd2' -D 'ovirt_build_extra_flags -gs 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/artifactory-ovirt-org-settings.xml'
>  -D '_srcrpmdir 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo'
>  -D '_specdir 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo'
>  -D '_sourcedir 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo'
>  -D '_rpmdir 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo'
>  -D '_builddir 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo'
>  --rebuild 
> /home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo/ovirt-engine-4.1.0-0.0.master.20161014001903.el7.centos.src.rpm
> + return 1
> Build step 'Execute shell' marked build as failure
> Performing Post build task...
> Match found for :.* : True
> Logical operation result is TRUE
> Running script  : #!/bin/bash -x
>
>
> Best Regards,
>
>

Rpmbuild fails on:
error: Failed build dependencies:
hystrix-core is needed by
ovirt-engine-4.1.0-0.0.master.20161014004451.git32a6f0c.el7.centos.noarch
hystrix-metrics-event-stream is needed by
ovirt-engine-4.1.0-0.0.master.20161014004451.git32a6f0c.el7.centos.noarch
Installing
/home/jenkins/workspace/ovirt-engine_master_upgrade-from-3.6_el7_created/tmp_repo/ovirt-engine-4.1.0-0.0.master.20161014004451.el7.centos.src.rpm

I'll check why those rpms are missing.






>
> Roman
>
>
> _______________________________________________
> Infra mailing list
> Infra@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/infra
>
>


-- 
Sandro Bonazzola
Better technology. Faster innovation. Powered by community collaboration.
See how it works at redhat.com
<https://www.redhat.com/it/about/events/red-hat-open-source-day-2016>
_______________________________________________
Infra mailing list
Infra@ovirt.org
http://lists.ovirt.org/mailman/listinfo/infra

Reply via email to