Barak Korren created OVIRT-2032:

             Summary: Mounting device files prevents using systemd-nspawn in 
                 Key: OVIRT-2032
             Project: oVirt - virtualization made easy
          Issue Type: Bug
          Components: mock_runner
            Reporter: Barak Korren
            Assignee: infra

The systemd-nspawn functionality in mock is introduced in OVIRT-2031.

When using systemd-nspawn mock uses some kind of a layered FS that is created 
when it starts and removed when it exits. This is different from the way it 
works when using chroot where the directory that the chroot is configured in 
stays around until it is explicitly removed.

mock had an issue where if you tried to bind-mount something into the mock 
environment, you had to have the mount point ready for it. We worked around 
this in {{mock_runner}} by using  the fact the chroot was persistent, going 
into it and setting up the mount points as needed before actually starting to 
use it to run the STDCI script.

Since the mock authors were aware of the issue when the implemented the 
systemd-nspawn  functionality, they made mock pre-create mount point in the 
container as needed. However, they only supported directory mount points, so if 
we tried to bind-mount a socket we would get en error message failing to mount 
a socket file on a directory.

We reported this issue to the mock developers as issue 

This message was sent by Atlassian Jira
Infra mailing list --
To unsubscribe send an email to

Reply via email to