On 03/10/2018 02:35 PM, Eg. Bo. wrote:
> Hello,
> who could help in resolving an issue with an AWS S3 mirror ?
> I'd like to download the epel release package using this URL:
> On my PC (proxy) I can download the file however if I run wget on EC2
instances (tried different accounts) in region eu-west-1 this ends up in
> [ec2-user@ip ~]$ wget
> --2018-03-10 03:30:12--
> Resolving download.fedoraproject.org (download.fedoraproject.org)...,,, ...
> Connecting to download.fedoraproject.org
(download.fedoraproject.org)||:80... connected.
> HTTP request sent, awaiting response... 302 Found
> Location:
> --2018-03-10 03:30:12--
> Resolving s3-mirror-eu-west-1.fedoraproject.org
> Connecting to s3-mirror-eu-west-1.fedoraproject.org
(s3-mirror-eu-west-1.fedoraproject.org)||:80... connected.
> HTTP request sent, awaiting response... 404 Not Found
> 2018-03-10 03:30:12 ERROR 404: Not Found.
> [ec2-user@ip ~]$
> The link
isn't also valid on my PC.
> Please help/fix.

Yeah, this is because that url points to just a link on our master
mirrors to help folks install the latest version of that package.

Where did you get the download.fedoraproject.org url for it?

You can use:


which will use the master mirrors for it.

As for fixing it on AWS, I suppose we could add some logic to our
mirroring to also copy up the latest epel-release version as that
'latest' link. We should make sure it auto updates though so we aren't
publishing a stale package.

Ricky: can you look into adding that to the existing sync script?


Attachment: signature.asc
Description: OpenPGP digital signature

infrastructure mailing list -- infrastructure@lists.fedoraproject.org
To unsubscribe send an email to infrastructure-le...@lists.fedoraproject.org

Reply via email to