> -----Original Message-----
> From: Intel-wired-lan <[email protected]> On Behalf Of
> Loktionov, Aleksandr
> Sent: Monday, June 8, 2026 8:11 AM
> To: Zaremba, Larysa <[email protected]>; intel-wired-
> [email protected]; Nguyen, Anthony L <[email protected]>
> Cc: Lobakin, Aleksander <[email protected]>; Samudrala, Sridhar
> <[email protected]>; Michal Swiatkowski
> <[email protected]>; Zaremba, Larysa
> <[email protected]>; Fijalkowski, Maciej
> <[email protected]>; Tantilov, Emil S <[email protected]>;
> Chittim, Madhu <[email protected]>; Hay, Joshua A
> <[email protected]>; Keller, Jacob E <[email protected]>;
> Shanmugam, Jayaprakash <[email protected]>; Jiri Pirko
> <[email protected]>; David S. Miller <[email protected]>; Eric Dumazet
> <[email protected]>; Jakub Kicinski <[email protected]>; Paolo Abeni
> <[email protected]>; Simon Horman <[email protected]>; Jonathan
> Corbet <[email protected]>; Richard Cochran <[email protected]>;
> Kitszel, Przemyslaw <[email protected]>; Andrew Lunn
> <[email protected]>; [email protected]; linux-
> [email protected]; [email protected]
> Subject: Re: [Intel-wired-lan] [PATCH iwl-next v8 07/15] idpf: remove unused
> code for getting RSS info from device
> 
> 
> 
> > -----Original Message-----
> > From: Intel-wired-lan <[email protected]> On Behalf
> > Of Larysa Zaremba
> > Sent: Monday, June 8, 2026 4:41 PM
> > To: [email protected]; Nguyen, Anthony L
> > <[email protected]>
> > Cc: Lobakin, Aleksander <[email protected]>; Samudrala,
> > Sridhar <[email protected]>; Michal Swiatkowski
> > <[email protected]>; Zaremba, Larysa
> > <[email protected]>; Fijalkowski, Maciej
> > <[email protected]>; Tantilov, Emil S
> > <[email protected]>; Chittim, Madhu <[email protected]>;
> > Hay, Joshua A <[email protected]>; Keller, Jacob E
> > <[email protected]>; Shanmugam, Jayaprakash
> > <[email protected]>; Jiri Pirko <[email protected]>;
> > David S. Miller <[email protected]>; Eric Dumazet
> > <[email protected]>; Jakub Kicinski <[email protected]>; Paolo Abeni
> > <[email protected]>; Simon Horman <[email protected]>; Jonathan
> Corbet
> > <[email protected]>; Richard Cochran <[email protected]>; Kitszel,
> > Przemyslaw <[email protected]>; Andrew Lunn
> > <[email protected]>; [email protected]; linux-
> > [email protected]; [email protected]
> > Subject: [Intel-wired-lan] [PATCH iwl-next v8 07/15] idpf: remove
> > unused code for getting RSS info from device
> >
> > idpf_send_get_set_rss_lut_msg() and idpf_send_get_set_rss_key_msg() do
> > not handle the get=true path properly. Response validation is
> > insufficient, memcpy size is wrong, LE-to-CPU conversion is missing.
> > Fortunately, those functions are never used with get=true. Given how
> > broken this dead code is, it is unlikely to be useful in the future.
> >
> > Rename idpf_send_get_set_rss_lut_msg() to idpf_send_set_rss_lut_msg(),
> > idpf_send_get_set_rss_key_msg() to idpf_send_set_rss_key_msg(), remove
> > the get parameter and remove all get=true cases from the function.
> >
> > Reviewed-by: Alexander Lobakin <[email protected]>
> > Signed-off-by: Larysa Zaremba <[email protected]>
> > ---
> >  drivers/net/ethernet/intel/idpf/idpf_txrx.c   |   4 +-
> >  .../net/ethernet/intel/idpf/idpf_virtchnl.c   | 107 +++--------------
> > -
> >  .../net/ethernet/intel/idpf/idpf_virtchnl.h   |  10 +-
> >  3 files changed, 22 insertions(+), 99 deletions(-)
> >
> > diff --git a/drivers/net/ethernet/intel/idpf/idpf_txrx.c
> > b/drivers/net/ethernet/intel/idpf/idpf_txrx.c
> > index f6b3b15364ff..d744db0efd3f 100644
> > --- a/drivers/net/ethernet/intel/idpf/idpf_txrx.c
> > +++ b/drivers/net/ethernet/intel/idpf/idpf_txrx.c
> > @@ -4679,11 +4679,11 @@ int idpf_config_rss(struct idpf_vport *vport,
> > struct idpf_rss_data *rss_data)
> >     u32 vport_id = vport->vport_id;
> >     int err;
> >
> 
> ...
> 
> > vport_id);
> >  void idpf_vc_xn_shutdown(struct idpf_vc_xn_manager *vcxn_mngr);  int
> > idpf_idc_rdma_vc_send_sync(struct iidc_rdma_core_dev_info *cdev_info,
> >                            u8 *send_msg, u16 msg_size,
> > --
> > 2.47.0
> 
> 
> Reviewed-by: Aleksandr Loktionov <[email protected]>

Tested-by: Samuel Salin <[email protected]>

Reply via email to