> -----Original Message-----
> From: Intel-wired-lan <[email protected]> On Behalf Of 
> Marcin Szycik
> Sent: 02 July 2026 16:00
> To: [email protected]
> Cc: [email protected]; Penigalapati, Sandeep 
> <[email protected]>; S, Ananth <[email protected]>; 
> [email protected]; Nguyen, Anthony L <[email protected]>; 
> Marcin Szycik <[email protected]>; Loktionov, Aleksandr 
> <[email protected]>
> Subject: [Intel-wired-lan] [PATCH iwl-next v5 01/12] ice: rename shared Flow 
> Director functions and structs
>
> From: Tony Nguyen <[email protected]>
>
> Rename shared Flow Director functions and structs. These entities are 
> currently used to add Flow Director filters, however, they will be expanded 
> to also add ACL filters. Rename the functions and struct, replacing 'fdir' to 
> 'ntuple', to reflect that they are being used for ntuple filters and are not 
> solely used for Flow Director.
>
> Rename the file to also reflect this change.
>
> Co-developed-by: Paul M Stillwell Jr <[email protected]>
> Signed-off-by: Paul M Stillwell Jr <[email protected]>
> Signed-off-by: Tony Nguyen <[email protected]>
> Reviewed-by: Aleksandr Loktionov <[email protected]>
> Co-developed-by: Marcin Szycik <[email protected]>
> Signed-off-by: Marcin Szycik <[email protected]>
> ---
> v5:
> * Also rename fdir_active_fltr to ntuple_active_fltr_cnt, as it will
>   track the sum of fdir and ACL filters in future patches
> * Also rename ice_fdir_update_cntrs() to ice_ntuple_update_cntrs(),
>   move it to ice_ethtool_ntuple.c, and make it static. In future patches
>   it will handle both fdir and ACL
> * ice_ntuple_update_cntrs(): join variable initialization and declaration
> v2:
> * Also rename struct ice_fdir_fltr and file
> ---
> drivers/net/ethernet/intel/ice/Makefile       |  2 +-
> drivers/net/ethernet/intel/ice/ice.h          |  6 +-
> drivers/net/ethernet/intel/ice/ice_arfs.h     |  2 +-
> drivers/net/ethernet/intel/ice/ice_fdir.h     | 14 ++-
> drivers/net/ethernet/intel/ice/ice_type.h     |  4 +-
> drivers/net/ethernet/intel/ice/ice_arfs.c     |  8 +-
> drivers/net/ethernet/intel/ice/ice_ethtool.c  |  9 +-  ...ce_ethtool_fdir.c 
> => ice_ethtool_ntuple.c} | 85 ++++++++++++-------
> drivers/net/ethernet/intel/ice/ice_fdir.c     | 38 ++-------
> drivers/net/ethernet/intel/ice/virt/fdir.c    | 28 +++---
> 10 files changed, 98 insertions(+), 98 deletions(-)  rename 
> drivers/net/ethernet/intel/ice/{ice_ethtool_fdir.c => ice_ethtool_ntuple.c} 
> (95%)
>

Tested-by: Rinitha S <[email protected]> (A Contingent worker at Intel)

Reply via email to