On terça-feira, 11 de outubro de 2016 08:43:23 CEST Robert Iakobashvili wrote:
> Hi,
> Configuring Qt-5.6.2 at the recent Mac 10.12
> with C++-11 built versus SDK-12 as:

Why are you downgrading to C++11? Are there any problems with the newer 
versions? If so, we should know so we can fix them.

> When trying -no-c++11 flag, Qt was using the old C++ library libstdc++,
> but clang was warning about its deprecation and suggesting to use
> the new C++ library "available since 10.9 target".

I thought we defaulted to libc++ even in non-C++11 case...

In fact, the 5.5 changelog says:

 - Support for the following platforms or toolchains is deprecated in Qt
   5.5 and will be removed as of Qt 5.6:
   * Apple OS X builds using GNU libstdc++

> Qt in its turn sets 10.7 as the minimal deployment target.
> 
> The question is at which minimal deployment target it will work?
> 10.7?
> 10.8?
> 10.9?

Qt 5.6 still supports 10.7.

-- 
Thiago Macieira - thiago.macieira (AT) intel.com
  Software Architect - Intel Open Source Technology Center

_______________________________________________
Interest mailing list
Interest@qt-project.org
http://lists.qt-project.org/mailman/listinfo/interest

Reply via email to