On Tue, Oct 11, 2016 at 9:51 AM, Thiago Macieira
<thiago.macie...@intel.com> wrote:
> On terça-feira, 11 de outubro de 2016 09:26:02 CEST Robert Iakobashvili wrote:
>> > Qt 5.6 still supports 10.7.
>>
>> The question is if Apple supports it with libc++?
>>
>> Here's the exact warning when building with -no-c++11 flag:
>>
>> "clang: warning: libstdc++ is deprecated; move to libc++ with a minimum
>> deployment target of OS X 10.9"
>>
>> And libc++.dylib was available at 10.7 - sort of contradiction.
>
> Ah, I see what you mean. You're saying libc++ was available in 10.7 but Apple
> is saying to use a minimum deploy target of 10.9.
>
> Sorry, no clue.
>
> --
> Thiago Macieira - thiago.macieira (AT) intel.com
>   Software Architect - Intel Open Source Technology Center

It might be that Apple states 10.9 and not 10.7 because
from their point of view 10.8 and 10.7 are not supported any more.

If somebody has 10.7 or 10.8 targets and can check that libc++ linked
Qt applications built with clang-8, sdk-12, are still running on 10.7 and 10.8,
that would be appreciated.

Thanks.

Kind regards,
Robert
_______________________________________________
Interest mailing list
Interest@qt-project.org
http://lists.qt-project.org/mailman/listinfo/interest

Reply via email to