Il 07/03/2018 00:16, Nuno Santos ha scritto:
Does anyone knows which modules we need to have compiled in order to make svg support work?


I depend on a static build of Qt and while I was able to use SVG with the prebuilt Qt, I couldn’t make use of it using my static build.

I realised I was missing qtsvg module but even after including it in the build it still says "unsupported graphic format”

Any ideas?

You need

QTPLUGIN += qsvg

in your .pro. See

https://doc.qt.io/qt-5/plugins-howto.html#static-plugins

HTH,

--
Giuseppe D'Angelo | giuseppe.dang...@kdab.com | Senior Software Engineer
KDAB (France) S.A.S., a KDAB Group company
Tel. France +33 (0)4 90 84 08 53, http://www.kdab.com
KDAB - The Qt, C++ and OpenGL Experts

Attachment: smime.p7s
Description: Firma crittografica S/MIME

_______________________________________________
Interest mailing list
Interest@qt-project.org
http://lists.qt-project.org/mailman/listinfo/interest

Reply via email to