On Monday, 22 August 2022 09:11:29 -03 Michael Jackson wrote:
> For our open source program we create self-contained .tar.gz archives for
> users to download. Currently we use Qt5.15.2 for those archives. After
> packaging I run a sanity check on my Ubuntu 20.04 fully patched system and
> the program will launch just fine. It is a GUI based program. Last week 2
> users reported that when the launch the program on their Ubuntu 20.04
> systems they get an error when one of our Plugins loads (we use Qt's plugin
> infrastructure to load) that basically says the plugin cannot load because
> Qt5OpenGL.so could not be loaded. That library is in the proper location
> (alongside all of the other libraries in the install). I'm not a linux guy
> and Googling didn't really turn anything up that was helpful. We dropped
> back to an older version of our program where I built against Qt5.9 and
> those binaries worked just fine. I'm looking for advice on what might be
> the issue? OpenGL drivers (The user's machine was using a Mesa install
> running on an Intel HDXXXX hardware). I think we actually build on Ubuntu
> 18.04 but we build against the Qt5.15 binaries from Qt.io instead of system
> installed Qt binaries. Maybe that is the issue? Advice is appreciated.

Please have them run with QT_DEBUG_PLUGINS=1 and send you the output. There'll 
be a line there saying that the plugin failed to load because something 
happened. It's probably a missing system library.

Have your users install that if it is the case.

Thiago Macieira - thiago.macieira (AT) intel.com
  Cloud Software Architect - Intel DCAI Cloud Engineering

Interest mailing list

Reply via email to