Hello Cristiano,

Monday, August 4, 2003, 8:45:20 AM, you wrote:

>> CD> Should the method be named "to_string()", "tostring()" or
CD> "__tostring()" ?

Maybe the __tostring() will be the best because few naming
conventions for methods exist. Some people prefer C-like some_method(), some
like Java-like someMethod() etc. But there is already in PHP5
pre-defined methods like __clone, __construct, __destruct so the
"__tostring" name will be expected by user. The "__to_string" will
also be though. I have seen no "__" methods with names having two
words so this variants are equal from my point of view.

CD> I modified the code to just call to_string if the object implements the
CD> "printable" interface.

The printable is IMHO definetly not good name for such interface. When
user sees the "implements Printable" he expects methods like
print(), println() etc. that do something, not return strings.
I can't name this interface better though.
Maybe it will be better to have this method in all classes and define
default behavior such as existing ( string )$object cast?

-- 
Best regards,
 Simeon                            mailto:[EMAIL PROTECTED]


-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to